IE错误“Java(TM) 已被阻止,因为它已过时并且需要更新。”的解决方法

君子不器 2016年03月09日 编程世界 4707次阅读 查看评论

 

自今年9月10日,大量用户反馈,登陆到Oracle E-Business Suite后再点FormIE 弹出“Java(TM)已被阻止,因为它已过时并且需要更新。 ”的错误,这个错误造成用户无法打开 Oracle EBS(其实不光是Oracle EBS,其他很多网站/系统都可能遇到类似的问题,这里只是以EBS为例来说了)。

英文错误:Java(TM) was blocked because it is out of date and needs to be updated.


原因:
经查,这个提示是因为微软2014年9月9IE浏览器启用一个叫Out-of-date ActiveX control blocking的新特性。此特性会检查 IE插件的版本是否为最新版本,如果不是最新版本,则要求用户升级组件。对于 Oracle EBS来时,微软会检查JRE的版本,因为现阶段我们的Oracle EBS只支持到 JRE 1.6,所以客户端也只能使用旧的 JRE1.6的插件,客户端升级JRE会造成其他不能登录的问题。

解决方法:
如果你确实充分信任你访问的网站(比如内部系统),推荐的解决方法是添加访问网址到信任站点,微软就不会因为插件版本低而阻止用户继续使用了。

注意:需要去掉 “对该区域中的所有站点要求服务器验证 (https:)”的勾,才能添加网址,网址开头是 http,不要带https

===更新2014.9.29===
Oracle EBS用户可以关注下,Oracle EBS也对微软此更新做了官方的说明和解决方法的推荐,和我说的一样,Oracle官方推荐的解决方法还是把Oracle EBS站点的网址加入信任站点,跳过微软的插件检查,见Recommended Browsers for Oracle E-Business Suite Release 12 (Doc ID 389422.1)


参考:
Preventing "Java was blocked" IE Warnings with Oracle EBS 
Recommended Browsers for Oracle E-Business Suite Release 12 (Doc ID 389422.1)


« 上一篇 下一篇 » 君子不器原创文章,转载请注明出处! 标签:Java

相关日志:

博主介绍
乌云蔽月,人迹踪绝,说不出如斯寂寞。
控制面板
您好,欢迎到访网站!
  [查看权限]
站点信息
  • 文章总数:1279
  • 页面总数:2
  • 分类总数:9
  • 标签总数:61
  • 评论总数:331
标签列表
友情链接